Support des navigateurs obsolètes par la branche 1 de jQuery

Le , par danielhagnoul, Rédacteur
Support des navigateurs obsolètes par la branche 1 de jQuery
Avertissement concernant les modifications à venir

La sortie de la version 1.12 est programmée pour le dernier trimestre de l'année 2014. Cette version sera toujours compatible avec IE 6 et plus. Ce sera la dernière version de jQuery compatible avec Opera 12.1x et Safari 5.1.

L'année prochaine (2015), nous sortirons la version 1.13. Elle sera compatible avec IE 8 et plus. Le support de IE6 et de IE 7 sera supprimé.

Le mythe de la cohérence des navigateurs non obsolètes

La branche 2 de jQuery contiendra encore longtemps des correctifs spécifiques aux divers navigateurs pour normaliser leurs comportements .

Pour l'instant, le navigateur le plus problématique pour jQuery 2.x est celui d'Android 2.3 . Cette version représente encore 20 % de la base installée d'Android. Plusieurs fonctionnalités JavaScript comme element.classList ne sont pas prises en charge, et il est l'un des derniers navigateurs à toujours exiger le préfixe -webkit- pour les propriétés CSS normalisées .

Nous allons continuer le support des correctifs qui sont nécessaires pour aplanir les divergences des navigateurs populaires. Mais dès que le support d'un navigateur n'est plus nécessaire, nous pouvons retirer les patchs spécifiques et normaliser nos codes. Cela rend toutes les pages jQuery un peu plus rapides.

Source


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :
Offres d'emploi IT
Conception et développement IHM WEB (h-f)
Atos - Midi Pyrénées - Toulouse (31000)
Expert Webdesigner
AMETIX - Ile de France - Paris (75000)
Ingenieur web - PHP (H/F)
Atos - Provence Alpes Côte d'Azur - Sophia Antipolis

Voir plus d'offres Voir la carte des offres IT
Responsable bénévole de la rubrique Développement Web : Xavier Lecomte -